AI"C G IS® for Desktop

Tips and Shortcuts




Map Navigation

Function
Refresh and redraw the display.
Suspend the map’s drawing.

Zoom in and out.

Center map.

Pan.

In layout view, apply the three mouse
navigation shortcuts listed above to the
data frame rather than the page.

Roam.

Zoom in on box you define.

Temporarily change to Zoom In tool.
Temporarily change to Zoom Out tool.
Temporarily change to Pan tool.

Temporarily change to Continuous Zoom/
Pan tool.

Nudge or scroll map.

Go back to the previous extent.
Go forward to the next extent.

Open context menu of useful commands.

Toggle among Zoom In tool, Zoom Out
tool, or Pan tool when one is active.

Go to full extent.

Zoom to layer’s extent.

Shortcut
F5
F9

Roll the mouse wheel backward
and forward. Hold down Ctrl for a
finer zoom. To switch direction of
the mouse roll, go to the ArcMap™
Options dialog box.

Click mouse wheel. Ctrl + click to
center and zoom in.

Hold down mouse wheel and drag.

Hold down Shift while you perform
the shortcut with the mouse.

Hold down Q and move mouse, or
hold down mouse wheel until cursor
changes, then drag mouse.

Ctrl + hold down mouse wheel and
drag.

Hold down Z.
Hold down X.
Hold down C.
Hold down B.

Arrow keys or Home, End, Page Up,
Page Down

<
>

Right-click map in data view with any
tool.

F6

Insert

Alt + click layer name in the table of
contents.
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Table of Contents Window

Function

Put keyboard focus on the Table of
Contents window.

Put keyboard focus back on the map from
the Table of Contents window (or the
Catalog window in ArcGIS® 10).
Expand/Contract selected items.
Expand/Contract all the items at that level.
Turn on/off selected layers.

Turn on/off all layers.

Turn on/off all layers at that hierarchical
level or all selected layers.

Activate data frame.

Cycle through each data frame and
activate it.

Open context menu for selected item.
Rename selected item.

Open Properties dialog box of a selected
item.

Select multiple layers in the Table of
Contents window.

Copy layers inside a data frame instead of
reordering them, or move layers between
data frames instead ofcopying.

Select the first item in the Table of
Contents window.

Select the last item in the Table of
Contents window.

Turn layer you clicked on; turn all other
layers off.

Shortcut

F3 (or click inside the table of
contents [TOC])

Esc (or click the map)

Left/Right arrows or + and - keys
Ctrl + click an expansion control
Spacebar

Ctrl + spacebar

Ctrl + click a check box

F11 (or Alt + click data frame’s name)

Ctrl + Tab

Shift + F10 or right-click
F2

F12 (or Enter)

Ctrl + click or Shift + click

Hold down Ctrl and drag and drop.

Home

End

Alt + click check box on TOC
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Tables

Function

View multiple tables side by side in the
table window.

Toggle between tables in the table
window.

Open table for any item in the table of
contents.

Open tables for selected items in table
of contents.

Open context menu of field
management commands.

Open context menu of selection and
navigation commands.

Sort field.

Turn off any field.

Turn off current field.

Zoom in and out on table window.

Select all records.

Deselect all records.

Switch selection.

Deselect row.

Work sequentially through table,
selecting each record in turn.

Go to cell below.

Go to cell to right and wrap around to
next row down.

Go to first cell in the current column.
Go to last cell in the current column.

Zoom to selected features.

Shortcut

Inside the table window, drag and
drop a table’s tab to the desired
position.

Ctrl + tab

Ctrl + double-click

Ctrl + T or Ctrl + Enter

Right-click field name.

Right-click gray cell to the left of a
record.

Double-click field name.

Ctrl + double-click field name
Ctrl + H

Ctrl + roll mouse wheel

Ctrl + A (or Shift + click top left gray
cell)

Ctrl + Shift + A (or click top left gray
cell)

Ctrl + U (or Ctrl + click top left gray
cell)

Backspace

Ctrl + Enter

Enter

Tab

Ctrl + up arrow
Ctrl + down arrow

Ctrl + Shift + =
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Tables

(continued)

Function

Flash the current feature.

Zoom to the current feature.

Pan to the current feature and flash it.
Identify the current feature.

Zoom to feature represented by a record
and select it.

Start or stop an edit session.

Copy current cell value or selected
records to the clipboard.

Start editing a cell.

Cancel editing and restore cell’s original
value.

Delete the selected records during edit
session.

Restore default column widths.
Open Properties dialog box for a field.

Open Properties dialog box for the
current field.

Toggle between showing all field aliases
on/off.

Open Field Calculator dialog box for the
current field.

Open Calculate Geometry dialog box for
the current field.

Open Advanced Field Sorting dialog
box.

Unsort by setting all advanced sort
options to <None>.

Reselect highlighted records in Show
Selected Records mode.

Print the table.

Shortcut
Ctrl + 8
Ctrl + =
Ctrl + N
Ctrl + 1

Hold down Ctrl + double-click
gray cell to the left of record.

Ctrl+E
Ctrl + Shift+ C

F2

Esc

Delete

Ctrl + Shift + Z
Alt + double-click field name

Ctrl + Shift + P

Ctrl + Shift + N

Ctrl + Shift + F

Ctrl + Shift + G

Shift + double-click field name
(or Ctrl + Shift + S)

Ctrl + Shift + U

Ctrl + Shift + R

Ctrl+P
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Editing Features

Function

Create a segment parallel to an existing
one.

Create a segment perpendicular to an
existing one.

Create a segment at an exact angle.
Create a segment at an exact length.

Create a segment at an exact angle and
length.

Enter coordinate by value.

Delete the sketch.

Finish the sketch.

Finish a part of the sketch to create a
multipart feature.

Undo last edit.
Add a point to a sketch by delta x,y.

Temporarily suspend snapping
(especially useful when tracing along
features).

Open the Edit Sketch Properties
window.

Toggle between feature creation, Edit,
and Edit Annotation tools when one is
active.

Edit tool: Move the selection anchor
(the “x”) for a selected feature.

Edit tool: Toggle through selected
features within the selection tolerance
to select the correct one when there are
multiple overlapping features.

Shortcut

Ctrl + P or Constrain Parallel on
Feature Construction toolbar

Ctrl + E or Constrain
Perpendicular on Feature
Construction toolbar

Ctrl + A

Ctrl + L

Ctrl+ G

F6

Ctrl + Delete

F2

Shift + double-click

Ctrl +Z
Ctrl+ D

Spacebar

Hold down Ctrl while you hover
over the selection anchor.
When the pointer changes to
the “move” pointer, click the
selection anchor and drag it to
the new location.

N or click the selection chip.
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Editing Tips and Time-Savers
Tip

When editing in ArcMap, you can do on-the-fly unit conversion if you
specify the unit type when you type a distance.

Use the sticky move tolerance on the Editing Options dialog box to set a
minimum number of pixels your pointer must move on the screen before

a selected feature is moved. This helps prevent features from being
accidentally moved small distances when they are clicked with the Edit tool.

With the Customize dialog box open, drag the Start Editing, Stop Editing,
and Save Edits commands out of the Editor pull-down menu and onto the
Editor toolbar itself. In this way, you can access those commands with one
click.

Right-click with most editing tools to open a menu containing additional
commands. For example, the feature construction tools provide
commands that help you place vertices and segments.

Use feature templates to predefine the layer where a feature will be stored,
the attributes a feature will be created with, and the default tool to be
used to create that feature. Double-click a feature template in the Create
Features window to set up the editing environment with these properties.

Mini-toolbars provide quick access to commonly used commands when
editing. The Feature Construction toolbar helps you digitize segments,
and the Edit Vertices toolbar contains tools for selecting and manipulating
vertices. Press the Tab key to move or (in 10.1) temporarily show or hide the
Feature Construction toolbar.

Use the Editing Options dialog box to change the colors of the edit sketch
vertices and segments so they are easier to see when creating or editing
features, particularly when working over dark imagery.

Utilize snapping to position new vertices and segments and move

features more accurately. All the settings you need to work with snapping
are located on the Snapping toolbar. Snapping is also used by the
georeferencing tools, the Measure tool, and the interactive selection tools.

Use the Topology toolbar to build a map topology so you can make
simultaneous updates to features that are connected and share geometry.
Map topology and the topology editing tools are available at all ArcGIS for
Desktop license levels.

Enable editor tracking on your geodatabase datasets to record the date
and time when a feature is created or edited, and the username of the
editor who makes the changes. This information is entered automatically in
attribute fields in the dataset.

Introduced
9.1
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Representations

Function Shortcut Introduced
Activate/Switch between Select/Direct Select tools. G 9.3
Activate/Switch between Lasso Select/Lasso Direct Select L 9.3
tools.

Activate/Switch between Insert Vertex/Delete Vertex tools. | 9.3
Activate/Switch between Insert Bezier/Delete Bezier tools. u 9.3
Activate/Switch between Insert Control Point/Delete Control Y 9.3
Point tools.

Activate Warp tool. W 9.3
Activate Move Parallel tool. P 9.3
Activate Erase tool. E 9.3
Activate Mask tool. K 9.3
Activate Rotate tool and open the Angle dialog box. R 9.3
Activate Orient tool and open the Angle dialog box. o 9.3
Activate Resize tool and open the Ratio dialog box. S 9.3
Activate Move tool and open the Offsets dialog box. M 9.3
Activate Offset tool and open the Offsets dialog box. F 9.3
General Tips and Time-Savers

Tip Introduced
In any application, click Customize > Customize Mode to enter the mode 9.1
where you can drag controls around on any pull-down menus and toolbars

to rearrange the user interface the way you want. You don’t need to drag

controls out of the Customize dialog box; the dialog box just needs to be

open for you to rearrange the user interface.

In ArcGIS 10, drag a folder onto the Folder Connections top-level folder in 9.1
the Catalog window or in ArcCatalog” to make a folder connection to that

folder. (In previous releases, drag a folder onto the Catalog entry at the top

of the Catalog tree to create a folder connection toit.)

Rename your folder connections in the Catalog window or in ArcCatalog to 9.2

give them more meaningful names.




General Tips and Time-Savers (continued)

Tip
Use the Window > Viewer command or the Create Viewer Window tool on the
Data Frame Tools toolbar to open windows that let you view multiple scales at

once. Viewer windows are fully functioning live ArcMap displays, so all tools and
navigation shortcuts work inside them.

Control how far out the Full Extent button will take you by setting the full extent
property on the View Data Frame Properties dialog box Data Frame tab.

In a table, calculate area, length, perimeter, centroid, and point coordinates
by right-clicking the name of a text or numeric field and choosing Calculate
Geometry.

The Results window keeps a record of all the geoprocessing you have done
and lets you inspect, cancel, and review the outputs of processes. (Prior to
ArcGIS 10, the results are shown on a tab in the ArcToolbox™ window.)

Right-click any tool on the ArcToolbox window or Catalog and click Batch to
execute a geoprocessing tool multiple times with different inputs.

If you want to store useful extents and locations that you can zoom to
irrespective of the map document, you can do so using the My Places dialog
box. In ArcMap 10, this is on the Data Frame Tools toolbar. In previous versions,
it is on the Tools pull-down menu. It can also be accessed via the results list on
the Find dialog box, etc.

Your map document’s home folder is the folder in which the MXD file resides.
The Home button is available on various dialog boxes in ArcMap, providing a
shortcut to get you to that folder in a single click.

The Searchwindow makes it easy to find data, maps, and tools. The keyboard
shortcut to open this window is Ctrl + F. In the search results, click data to

add it to your current document. Clicking a document opens it in your current
application. Clicking a tool launches it. Click the summary text for an item to open
its Item Description window. Keep the Item Description window open and click
the summary text for another item to see its item description. Click the green path
shown for a local item to go to that location in the Catalog window.

To “fly out” an autohidden window (dockable window represented by a tab),
hover over or click its tab. To hide an autohidden window that you've “flown
out,” press the Esc key.

You can stack dockable windows on top of each other so only one of them is
visible at any time. When you drag a window, hover over the center of the docked
window you want to stack it with and drop it on the blue target that appears.
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General Tips and Time-Savers (continued)

Tip

To dock or undock any dockable window, double-click its title bar or, if it is stacked
with another docked window, double-click its tab.

After you open the Item Description window for any item in the Catalog window or
Search window, leave it open and click another item; the Item Description window
will automatically update to show you information for that item.

Before you create a layer package, enter description and credits information into
the layer’s Properties dialog box (General tab). The information you enter will be
accessible to users who find and work with your layer package.

Before you package or serve a map, enter description, credits, and other useful
information about it into the File > Map Document Properties dialog box and also
inthe View > Data Frame Properties dialog box (General tab). This will ensure that
users of your map package or map service will be able to find out more about it.

Additional ArcGIS Resources
ArcGIS Online: arcgis.com

What's New in ArcGIS: esri.com/whatsnew
ArcGlISResource Center:resources.arcgis.com
Support: esri.com/support

Training: esri.com/training

Books: esri.com/esripress

@ esri

marks, or registered marks of Esri in the United States, the European Ci or certain other

mentioned herein may be trademarks, service marks, or registered marks of their respective mark owners.
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